VS:SetPolyPt3D

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetPolyPt3D sets the position of the specified vertex in the referenced 3D object.

PROCEDURE SetPolyPt3D(
objectHd :HANDLE;
index :INTEGER;
pX,pY :REAL;
zValue :REAL);
def vs.SetPolyPt3D(objectHd, index, p, zValue):
    return None

Parameters

objectHd HANDLE Handle to mesh or 3D poly object.
index INTEGER Index of vertex point.
p REAL New X-Y coordinates of vertex.
zValue REAL New elevation of vertex.

Remarks

Please have a look at my comments on the VectorLab regarding this function, concerning index and origin.

Orso, 2010/09/12: Warning: From VW13 this function subtracts the layer Z to the passed z-value. So, for example, by a layer z of 10, if you pass z=1 the vertex will go to -9.

Example

VectorScript

SetPolyPt3D(objectHandle,3,2.5",3",8");

Python


Version

Availability: from MiniCAD7.0