VS:SetPolyPt

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetPolyPt sets the location a specified vertex in the referenced polygon.

PROCEDURE SetPolyPt(
objectHd :HANDLE;
index :INTEGER;
xR :REAL;
yR :REAL);
def vs.SetPolyPt(objectHd, index, xR, yR):
    return None

Parameters

objectHd HANDLE Handle to polygon.
index INTEGER Index of vertex.
xR REAL New X coordinate of vertex.
yR REAL New Y coordinate of vertex.

Remarks

(Gerard Jonker, 2007 Jan. 8) Please have a look at my comments on the VectorLab regarding this function, concerning index and origin.

(_c_, 2010 Dec. 25) From Raymond Mullin: It only works for Polygons, and not for Polylines.. Using this function on polylines will rise an invalid handle warning. Please be careful on conversions from polygon to polyline through InsertVertex or other routines. See SetPolylineVertex. I thus remove the word polylines from the description above.

Version

Availability: from All Versions

See Also

For polygons:

For polylines:

For polygons:
  • [[VS:GetPolyPt| GetPolyPt]]

For polylines:

  • [[VS:GetPolylineVertex| GetPolylineVertex]]
  • [[VS:SetPolylineVertex| SetPolylineVertex]]