VS:SetOriginAbsolute

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetOriginAbsolute sets the position of the origin relative to the center of the document drawing space.

PROCEDURE SetOriginAbsolute(
xValue :REAL;
yValue :REAL);
def vs.SetOriginAbsolute(xValue, yValue):
    return None

Parameters

xValue REAL X coordinate of origin.
yValue REAL Y coordinate of origin.

Remarks

The difference between VS:SetOrigin and VS:SetOriginAbsolute is that SetOrigin shifts the origin the specified amount, where VS:SetOriginAbsolute sets the origin to the specified values.

See the <a href=http://www.vectorlab.info/index.php?title=Absolute_Origin>VectorLab article</a> on origins by Gerard Jonker.

Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:SetOrigin

VS Functions: [[VS:SetOrigin]]