VS:SetEntityMatrixN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the matrix of the plane for a planar object. If there is already a plane in the document with that matrix, the object will be set to be in that plane. Otherwise a new plane will be added to the document.

FUNCTION SetEntityMatrixN(
objectHandle :HANDLE;
u :REAL;
v :REAL;
w :REAL;
offset :REAL) : BOOLEAN;
def vs.SetEntityMatrixN(objectHandle, u, v, w, offset):
    return BOOLEAN

Parameters

objectHandle HANDLE The object whose plane is being set.
u REAL The X, Y and Z values of the plane's u-vector in current document units.
v REAL The X, Y and Z values of the plane's v-vector in current document units.
w REAL The X, Y and Z values of the plane's w-vector in current document units.
offset REAL The X, Y and Z offsets of the plane in current document units.

Return Value

Returns True if data was set successfully, False otherwise.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetEntityMatrix

VS Functions: [[VS:SetEntityMatrix]]