VS:SetDimText

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SetDimText will set the dimension text of the referenced dimension to the specified value.

The maximum length for dimension text is 60 characters. The first 30 characters of the specified dimension text string will be displayed in the primary dimension string; the remaining characters will be displayed in the secondary dimension string, if it exists.

PROCEDURE SetDimText(
h :HANDLE;
leaderTrailer :STRING);
def vs.SetDimText(h, leaderTrailer):
    return None

Parameters

h HANDLE Handle to a dimension object.
leaderTrailer STRING Dimension text string.

Example

VectorScript

SetDimText(dimHandle,'Length varies');

Python


Version

Availability: from MiniCAD4.0