VS:SetCompUseClassRPW

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the use class pen weight for right pen flag of a component in an object.

FUNCTION SetCompUseClassRPW(
object :HANDLE;
componentIndex :INTEGER;
useClassPenWeightForRightPen :BOOLEAN) : BOOLEAN;
def vs.SetCompUseClassRPW(object, componentIndex, useClassPenWeightForRightPen):
    return BOOLEAN

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
useClassPenWeightForRightPen BOOLEAN Whether or not the component will use class attributes for its right pen weight.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCompUseClassRPW

VS Functions: [[VS:GetCompUseClassRPW]]