VS:ScreenPtToModelPt2D

From Vectorworks Developer
Revision as of 14:37, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Transforms a point from screen coordinate in plan rotation to the model coordinates.

PROCEDURE ScreenPtToModelPt2D(
VAR pX, pY :REAL);
def vs.ScreenPtToModelPt2D(p):
    return p

Parameters

pX REAL Input output parameter. X Coordinate of the point to be translated.
pY REAL Input output parameter. Y Coordinate of the point to be translated.

Remarks

Takes into account both translation and rotation.

Version

Availability: from VectorWorks13.0