VS:ProgressDlgStart: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(2 intermediate revisions by the same user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Start a progress context. This defines progress percentage and loop count for ProgressDlgYeld calls. LoopCount is fit in the Percentage of the progress</desc>
Start a progress context. This defines progress percentage and loop count for ProgressDlgYield calls. LoopCount is fit in the Percentage of the progress</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 39: Line 39:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
Samples can be found at [[VS:Progress Dialog]].
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
[[VS:ProgressDlgOpen]] | [[VS:ProgressDlgClose]] | [[VS:ProgressDlgSetTopMsg]] | [[VS:ProgressDlgSetBotMsg]] | [[VS:ProgressDlgSetMeter]] | [[VS:ProgressDlgStart]] | [[VS:ProgressDlgEnd]] | [[VS:ProgressDlgHasCancel]] | [[VS:ProgressDlgYield]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 12:59, 29 October 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Start a progress context. This defines progress percentage and loop count for ProgressDlgYield calls. LoopCount is fit in the Percentage of the progress

PROCEDURE ProgressDlgStart(
Percentage :REAL;
LoopCount :LONGINT);
def vs.ProgressDlgStart(Percentage, LoopCount):
    return None

Parameters

Percentage REAL
LoopCount LONGINT

Example

Samples can be found at VS:Progress Dialog.

Version

Availability: from Vectorworks 2015

See Also

VS:ProgressDlgOpen | VS:ProgressDlgClose | VS:ProgressDlgSetTopMsg | VS:ProgressDlgSetBotMsg | VS:ProgressDlgSetMeter | VS:ProgressDlgStart | VS:ProgressDlgEnd | VS:ProgressDlgHasCancel | VS:ProgressDlgYield

[[VS:ProgressDlgOpen]] | [[VS:ProgressDlgClose]] | [[VS:ProgressDlgSetTopMsg]] | [[VS:ProgressDlgSetBotMsg]] | [[VS:ProgressDlgSetMeter]] | [[VS:ProgressDlgStart]] | [[VS:ProgressDlgEnd]] | [[VS:ProgressDlgHasCancel]] | [[VS:ProgressDlgYield]]