VS:PopAttrs: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 21:46, 27 April 2008

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Restores the attribute, tool, and constraint settings saved by an earlier call to PushAttrs.

PROCEDURE PopAttrs;
def vs.PopAttrs():
    return None

Remarks

Calling this procedure more times than PushAttrs has been called during the execution of the script will crash VectorWorks.

Example

VectorScript

PROCEDURE Example;
BEGIN
PushAttrs;
PenFore(215);
PenBack(5);
PenPat(25);
PenSize(42);
PenPat(25);
SetConstrain('q');
CallTool(-201);
PopAttrs;
END;
RUN(Example);

Python


Version

Availability: from MiniCAD4.0

See Also

VS Functions:

VS:PushAttrs

VS Functions: [[VS:PushAttrs]]