VS:PointAlongPolyN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (add see also)
 
Line 56: Line 56:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
VS Functions:
* [[VS:PointAlongPoly]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 06:23, 25 January 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a point at the specified distance along the poly, and a vector tangent to the poly at that point. Similar to PointAlongPoly with an addition of an epsilon value.

FUNCTION PointAlongPolyN(
h :HANDLE;
dist :REAL;
epsilon :REAL;
VAR pt :VECTOR;
VAR tangent :VECTOR) : BOOLEAN;
def vs.PointAlongPolyN(h, dist, epsilon):
    return (BOOLEAN, pt, tangent)

Parameters

h HANDLE
dist REAL
epsilon REAL
pt VECTOR
tangent VECTOR

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS Functions:
  • [[VS:PointAlongPoly]]