VS:Num2StrF: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
(No difference)

Revision as of 14:35, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Num2StrF converts a specified REAL value into a string. The numeric value will be converted and displayed in the current unit settings of the drawing.

FUNCTION Num2StrF(
vDistance :REAL) : STRING;
def vs.Num2StrF(vDistance):
    return STRING

Parameters

vDistance REAL Numeric value.

Remarks

This appears not to work as advertised. The string value returned appears to be in inches no matter the unit settings of the document.

Example

oldnumValue:=23.45;
newStrValue:=Num2StrF(oldnumValue);
{would return 1'-11 1/2"}

Version

Availability: from All Versions