VS:NameClass

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new class in a VectorWorks document, which then become the active class.

If the specified class already exists, then it will become the active class of the document.

Note: Class names cannot exceed 63 characters.

PROCEDURE NameClass(
className :STRING);
def vs.NameClass(className):
    return None

Parameters

className STRING Name of class.

Example

VectorScript

NameClass('Revisions');
Rect(4,4,6,6);

{Create a class 'Revisions' in the document}
{The rectangle is then assigned this class }

Python


Version

Availability: from All Versions