VS:IsResourceReferenced: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (1 revision: new v)
 
(No difference)

Latest revision as of 16:45, 15 September 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns whether a resource is workgroup referenced, and if so, the path to the source document is returned.

FUNCTION IsResourceReferenced(
resource :HANDLE;
VAR pathname :STRING) : BOOLEAN;
def vs.IsResourceReferenced(resource):
    return (BOOLEAN, pathname)

Parameters

resource HANDLE Handle to the resource
pathname STRING On return, a string containing the path to the source document

Return Value

Returns true if the resource is referenced, false otherwise.

Example

PROCEDURE DoIt(h :HANDLE);
VAR
    pathname: STRING;
    isref: BOOLEAN;
BEGIN
    isref := IsResourceReferenced(h, pathname);
    IF (isref) THEN Message(pathname);
END;

Version

Availability: from Vectorworks 2024

See Also

VS Functions:

VS:IsLayerReferenced

VS Functions: [[VS:IsLayerReferenced]]