VS:IFC ExportWithUI: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 31: Line 31:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<return>TRUE on success, FALSE indicates failure.</return>
===== Return Values =====
 
TRUE on success, FALSE indicates failure.
-----------------------------------------------------------------------------------------------------------
</remark>
<remark></remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:57, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Exports IFC file, showing Export IFC Project dialog

PROCEDURE IFC_ExportWithUI(
bExpSingleObj :BOOLEAN);
def vs.IFC_ExportWithUI(bExpSingleObj):
    return None

Parameters

bExpSingleObj BOOLEAN Set to False.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_ExportWithUI(FALSE);
END;

RUN(Test);

Python

ok = vs.IFC_ExportWithUI(FALSE)

Version

Availability: from Vectorworks 2014