VS:IFC DMDeleteEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Deletes an entry from indicated object, from current IFC Data Mapping.
Deletes an Еntry group from indicated object, from current IFC Data Mapping.
</desc>
</desc>


Line 26: Line 26:
inStrObjName
inStrObjName
STRING
STRING
Object Name.


</line>
</line>
Line 31: Line 32:
inStrEntryName
inStrEntryName
STRING
STRING
Ifc Entry group name.


</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 40: Line 45:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
Assume we want to clear "IfcWall" Entry Group from the mapping for Wall Object:
 
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMDeleteEntry('Wall', 'IfcWall');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_DMDeleteEntry('Wall', 'IfcWall')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:49, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes an Еntry group from indicated object, from current IFC Data Mapping.

FUNCTION IFC_DMDeleteEntry(
inStrObjName :STRING;
inStrEntryName :STRING) : BOOLEAN;
def vs.IFC_DMDeleteEntry(inStrObjName, inStrEntryName):
    return BOOLEAN

Parameters

inStrObjName STRING Object Name.
inStrEntryName STRING Ifc Entry group name.

Return Value

TRUE on success, FALSE indicates failure.

Example

Assume we want to clear "IfcWall" Entry Group from the mapping for Wall Object:

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMDeleteEntry('Wall', 'IfcWall');
END;

RUN(Test);

Python

ok = vs.IFC_DMDeleteEntry('Wall', 'IfcWall')

Version

Available from: Vectorworks 2017