VS:HScale3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 61: Line 61:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[Ptr 07/17/2019]
[Ptr 07/17/2019] Unlike for the HScale2D command, scaleX, scaleY and scaleZ can NOT be negative. If so, the function does nothing.
Unlike for the HScale2D command, scaleX, scaleY and scaleZ can NOT be negative. If so, the function does nothing.


[Ptr 02/02/2024]
[Ptr 02/02/2024] This command doesn't work on symbols.
This command doesn't work on symbols.
</remark>
</remark>



Latest revision as of 11:52, 2 February 2024

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Scales a 3D object.

PROCEDURE HScale3D(
h :HANDLE;
centerX :REAL;
centerY :REAL;
centerZ :REAL;
scaleX :REAL;
scaleY :REAL;
scaleZ :REAL);
def vs.HScale3D(h, centerX, centerY, centerZ, scaleX, scaleY, scaleZ):
    return None

Parameters

h HANDLE
centerX REAL
centerY REAL
centerZ REAL
scaleX REAL
scaleY REAL
scaleZ REAL

Remarks

[Ptr 07/17/2019] Unlike for the HScale2D command, scaleX, scaleY and scaleZ can NOT be negative. If so, the function does nothing.

[Ptr 02/02/2024] This command doesn't work on symbols.

Version

Availability: from Vectorworks 2014