VS:GetZatXY: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(No difference)

Revision as of 18:22, 11 March 2009

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Z height at a point X,Y

FUNCTION GetZatXY(
hObject  : HANDLE;
X  : REAL;
Y  : REAL;
VAR outZ  : REAL) : BOOLEAN;
def vs.GetZatXY(hObject, X, Y):
    return (BOOLEAN, outZ)

Parameters

hObject HANDLE
X REAL
Y REAL
outZ REAL Output parameter.

Remarks

If you pass NIL, it will search inside all the visible layers in the document, using layer elevation.

If you pass layer handle it searches everything in that layer.

If you pass object, it returns you Z of (x,y) on this object.

Return value: true if outZ is found; false otherwise.

Returned outZ always takes into accout the layer elevation.

Version

Availability: from All Versions

This is drop-in function.