VS:GetVWRString

From Vectorworks Developer
Revision as of 15:17, 23 March 2016 by Root (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Replaces GetResourceString -- load a string from VWR file

More information about VWR files can be found here Vectorworks VWR Resources.

PROCEDURE GetVWRString(
VAR outputString :STRING;
resIdentifier :STRING;
stringIdentifier :STRING);
def vs.GetVWRString(resIdentifier, stringIdentifier):
    return outputString

Parameters

outputString STRING result value
resIdentifier STRING VWR identifier and path to vwstrings file
stringIdentifier STRING key in vwstrings file

Example

vwr = 'EnergyAnalysis/Strings/FormatDef_ThermalBridge.vwstrings'
formatName = vs.GetVWRString(vwr, 'FormatName' )
vs.AlrtDialog( formatName )

Version

Availability: from Vectorworks 2014