VS:GetTextStyleRef

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTextStyleRef returns the text style for the referenced object. The integer returned is the internal index of the text style used by this object.


If the text object is using class text style, this returns the effective style. You should use the *TextStyleByClass* functions to check and preserve by-class behavior.

FUNCTION GetTextStyleRef(
objectId :HANDLE) : LONGINT;
def vs.GetTextStyleRef(objectId):
    return LONGINT

Parameters

objectId HANDLE handle to object

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetTextStyleRef | VS:GetTextStyleRef | VS:SetTextStyleRefN | VS:GetTextStyleRefN | VS:SetTextStyleByClass | VS:SetTextStyleByClassN | VS:IsTextStyleByClass | VS:IsTextStyleByClassN

VS Functions:

[[VS:SetTextStyleRef]] | [[VS:GetTextStyleRef]] | [[VS:SetTextStyleRefN]] | [[VS:GetTextStyleRefN]] | [[VS:SetTextStyleByClass]] | [[VS:SetTextStyleByClassN]] | [[VS:IsTextStyleByClass]]

| [[VS:IsTextStyleByClassN]]