VS:GetTexSpaceOrientW

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTexSpaceOrientW returns the vector that describes the w-axis of the referenced texture (from world space to texture space).

PROCEDURE GetTexSpaceOrientW(
textureSpace :HANDLE;
VAR wXAxis :REAL;
VAR wYAxis :REAL;
VAR wZAxis :REAL);
def vs.GetTexSpaceOrientW(textureSpace):
    return (wXAxis, wYAxis, wZAxis)

Parameters

textureSpace HANDLE Handle to texture space.
wXAxis REAL Returns w-axis vector X component.
wYAxis REAL Returns w-axis vector Y component.
wZAxis REAL Returns w-axis vector Z component.

Remarks

Returns the vector that describes the w-axis of the texture (from world space to texture space)

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks8.0