VS:GetPolyPt/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定した多角形/曲線の頂点番号から頂点座標を返します。

PROCEDURE GetPolyPt(
objectHd :HANDLE;
index :INTEGER;
VAR p :REAL);
def vs.GetPolyPt(objectHd, index):
    return p

Parameters

objectHd HANDLE 多角形/曲線のハンドル
index INTEGER 頂点番号(1からnの範囲)
p REAL 頂点の座標

Example

for i := 1 to GetVertNum(thePoly) do
begin		
	GetPolyPt(thePoly, i, vertX, vertY);
end;	

Version

利用可能バージョン: MiniCAD