VS:GetPluginStyleSymbol: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 19:43, 16 September 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the handled to a symbol that defines the plug-in style for a given plug-in object.


FUNCTION GetPluginStyleSymbol(
hObject :HANDLE;
VAR hSymDef :HANDLE) : BOOLEAN;
def vs.GetPluginStyleSymbol(hObject, hSymDef):
    return (BOOLEAN, hSymDef)

Parameters

hObject HANDLE Handle to a plug-in object.
hSymDef HANDLE Hanlde to a symbol definition that contrains the plug-in style associated with hObject.

Return Value

TRUE if the object is styled.

FALSE if the object is uynstyled.

Version

Availability: from Vectorworks 2017