VS:GetPluginInfo

From Vectorworks Developer
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the name and attached parameter record of the currently executing plug-in. Use with menu command or tool item plug-ins.

FUNCTION GetPluginInfo(
VAR pluginName :STRING;
VAR recordHand :HANDLE) : BOOLEAN;
def vs.GetPluginInfo():
    return (BOOLEAN, pluginName, recordHand)

Parameters

pluginName STRING Name of plug-in.
recordHand HANDLE Handle to parameter record of plug-in.

Remarks

Maybe a new function class of "Plug-ins" would be more appropriate than "Objects - Custom".


Please mind that this routine returns obj type 48 (record instance). In case of command plug-ins this might be kind of unexpected. Use getObject'commandName') instead to access the obj type 47 (record definition).

Version

Availability: from VectorWorks8.5