VS:GetObjTypeProperties: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 19:25, 12 September 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Receives an object type and returns the properties of that object type

FUNCTION GetObjTypeProperties(
ObjectType :INTEGER) : INTEGER;
def vs.GetObjTypeProperties(ObjectType):
    return INTEGER

Parameters

ObjectType INTEGER Object type whose properties are desired

Return Value

Returns bit map of properties associated with an object's type

Example

This function should return kTermProp for type kTermNode, kLineProp for kLineNode and so on for all existing object types that are defined in Objs.TDType.h.

Version

Availability: from Vectorworks 2018