VS:GetLightDirection: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 22:16, 27 April 2008

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLightDirection returns the direction angles of the referenced light object.

PROCEDURE GetLightDirection(
h :HANDLE;
VAR panAngleR :REAL;
VAR tiltAngleR :REAL);
def vs.GetLightDirection(h):
    return (panAngleR, tiltAngleR)

Parameters

h HANDLE Handle to light.
panAngleR REAL Returns light pan angle.
tiltAngleR REAL Returns light tilt angle.

Version

Availability: from MiniCAD7.0