VS:GetFPathName

From Vectorworks Developer
Revision as of 17:12, 13 August 2008 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fully qualified path and filename of the active document.

FUNCTION GetFPathName( ) :STRING;
def vs.GetFPathName():
    return STRING

Parameters

Remarks

On the Mac, this returns gibberish if the file has not been saved yet. To trap for this, use GetFName to see if the filename starts with 'Untitled'.

On the Mac, it also returns gibberish if the file name is greater than 28 characters in length.

Example

PROCEDURE Example;
BEGIN
   Message(GetFPathName);
END;
Run(Example);

Version

Availability: from All Versions

This is drop-in function.