VS:GetFPathName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the fully qualified path and filename of the active document.
Returns the fully-qualified filename of the active document.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetFPathName() :STRING;
FUNCTION GetFPathName : STRING;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 20: Line 19:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<params>
<remark></remark>
<lineList ident=1>
<line>
 
 
 
</line>
</lineList>
</params>
 
 
-----------------------------------------------------------------------------------------------------------
<return>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
On the Mac, this returns gibberish if the file has not been saved yet. To trap for this, use GetFName to see if the filename starts with 'Untitled'.
 
On the Mac, it also returns gibberish if the file name is greater than 28 characters in length.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
BEGIN
  Message(GetFPathName);
END;
Run(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|GetFPathName]]
[[Category:VS Function Reference|GetFPathName]]
[[Category:VS Function Reference:Document Settings|GetFPathName]]
[[Category:VS Function Reference:File I/O|GetFPathName]]

Latest revision as of 17:38, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fully-qualified filename of the active document.

FUNCTION GetFPathName : STRING;
def vs.GetFPathName():
    return STRING

Version

Availability: from Vectorworks 2014