VS:GetCustomObjectInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetCustomObjectInfo is used within plug-in object scripts to determine information about the object. Returns TRUE when (objectHand <> NIL) AND (recordHand <> NIL)

FUNCTION GetCustomObjectInfo(
VAR objectName :STRING;
VAR objectHand :HANDLE;
VAR recordHand :HANDLE;
VAR wallHand :HANDLE) : BOOLEAN;
def vs.GetCustomObjectInfo():
    return (BOOLEAN, objectName, objectHand, recordHand, wallHand)

Parameters

objectName STRING Returns the name of the object.
objectHand HANDLE Returns a handle to the plugin object in the drawing.
recordHand HANDLE Returns a handle to the record containing current parameter values.
wallHand HANDLE Returns a handle to a wall, (if this object is in a wall).

Remarks

[sd 8/19/98]

Version

Availability: from VectorWorks8.0

See Also

VS Functions:

VS:IsNewCustomObject

VS Functions: [[VS:IsNewCustomObject]]