VS:GetCompWallAssMod

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the wall associated modification of a component in an object.

FUNCTION GetCompWallAssMod(
object :HANDLE;
componentIndex :INTEGER;
VAR wallAssociatedModification :INTEGER) : BOOLEAN;
def vs.GetCompWallAssMod(object, componentIndex):
    return (BOOLEAN, wallAssociatedModification)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
wallAssociatedModification INTEGER Returns the wall associated modification of the component. 0 - None 1 - Clip walls 2 - Clipped by walls

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompWallAssMod

VS Functions: [[VS:SetCompWallAssMod]]