VS:GetCompUseClassFill

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class fill style for fill flag of a component in an object.

FUNCTION GetCompUseClassFill(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassFillStyleForFill :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassFill(object, componentIndex):
    return (BOOLEAN, useClassFillStyleForFill)

Parameters

object HANDLE The object. Can be a wall, round wall, slab, roof face, roof, Wall Style, Slab Style, Roof Style, the Wall Preferences, the Slab Preferences, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassFillStyleForFill BOOLEAN Returns whether or not the component is using class attributes for its fill.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassFill

VS Functions: [[VS:SetCompUseClassFill]]