VS:GetCompUseClassASFCl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the use class fill colors for alternate section fill flag of a component in an object.

FUNCTION GetCompUseClassASFCl(
object :HANDLE;
componentIndex :INTEGER;
VAR useClassFillColorsForAlternateSectionFill :BOOLEAN) : BOOLEAN;
def vs.GetCompUseClassASFCl(object, componentIndex):
    return (BOOLEAN, useClassFillColorsForAlternateSectionFill)

Parameters

object HANDLE The object. Can be a roof face, roof, Roof Style, or the Roof Preferences.
componentIndex INTEGER The index of the component.
useClassFillColorsForAlternateSectionFill BOOLEAN Returns whether or not the component is using class attributes for its alternate section fill colors.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompUseClassASFCl

VS Functions: [[VS:SetCompUseClassASFCl]]