VS:GetCompAutoJoinCap

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the always auto join in Capped Join mode flag of a component in an object.

FUNCTION GetCompAutoJoinCap(
object :HANDLE;
componentIndex :INTEGER;
VAR alwaysAutoJoinInCappedJoinMode :BOOLEAN) : BOOLEAN;
def vs.GetCompAutoJoinCap(object, componentIndex):
    return (BOOLEAN, alwaysAutoJoinInCappedJoinMode)

Parameters

object HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
componentIndex INTEGER The index of the component.
alwaysAutoJoinInCappedJoinMode BOOLEAN Returns whether or not the component always auto joins in Capped Join mode.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:SetCompAutoJoinCap

VS Functions: [[VS:SetCompAutoJoinCap]]