VS:GetCharColor

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetCharColor returns the color of a character at a specified position in the given text object.

The position is in a range between 0 and 32767, representing a character position in the text string. An index of 0 refers to the first character in the string.

PROCEDURE GetCharColor(
theText :HANDLE;
position :INTEGER;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetCharColor(theText, position):
    return (red, green, blue)

Parameters

theText HANDLE Handle of the text object
position INTEGER Position of the character in the text string (0-based)
red LONGINT
green LONGINT
blue LONGINT

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetCharFontIndex | VS:GetCharSize | VS:GetCharStyle

VS Functions:

[[VS:GetCharFontIndex]] | [[VS:GetCharSize]]

| [[VS:GetCharStyle]]