VS:FillFore: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:30, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure FillFore sets the active fill foreground color setting for the document. RGB values are in the range of 0~65535.

PROCEDURE FillFore(
color :LONGINT);
def vs.FillFore(color):
    return None

Parameters

color LONGINT RGB color value to set as active fill foreground color.

Remarks

This routine will also accept a color index, see Index Pitfalls, Colors

Example

VectorScript

FillFore(65535,0,39321); { using RGB values }
FillFore(7); { using Color Index values }

Python

vs.FillFore(65535,0,39321) #{ using RGB values }
vs.FillFore(7) #{ using Color Index values }

Version

Availability: from All Versions

See Also

VS Functions:

VS:RGBToColorIndex | VS:ColorIndexToRGB

VS Functions:

[[VS:RGBToColorIndex]]

| [[VS:ColorIndexToRGB]]