VS:ExtrudeAlongPath: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add remark about generic solid)
m (Transfer Orso to _c_, wikify)
 
Line 44: Line 44:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
[[User:Orso.b.schmid|Orso]], 2018.05.13: The generated extrusion is a Generic Solid and won't take the active class attributes, while CreateExtrudeAlongPath will create a number of NURBS curves with class attributes, but they won't section properly in Section Viewports without stitch and trim, since they don't generate a fill. Tested in Pio: OK.
[[User:CBM-c-|_c_]], 2018.05.13: The generated extrusion is a Generic Solid and won't take the active class attributes, while CreateExtrudeAlongPath will create a number of NURBS curves with class attributes, but they won't section properly in Section Viewports without stitch and trim, since they don't generate a fill. Tested in Pio: OK.




-----
-----
The generic solid can not be edited<BR>
The generic solid can not be edited
<BR>
 
The following objects are supported as profile objects:<BR>
The following objects are supported as profile objects:
<BR>
 
Line               2<BR>
* 2 - Line
Box               3<BR>
* 3 - Box
Oval               4<BR>
* 4 - Oval
Polygon         5<BR>
* 5 - Polygon
Arc               6<BR>
* 6 - Arc
Freehand       8<BR>
* 8 - Freehand
R Rect           13<BR>
* 13 - R Rect
Polyline       21<BR>
* 21 - Polyline
3D Poly       25<BR>
* 25 - 3D Poly
NURBS Curve 111<BR>
* 111 - NURBS Curve
<BR>
<BR>
</remark>
</remark>



Latest revision as of 05:27, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new path extrude object in the document. The profile defines the shape of the cross-section, and is extruded along the path to generate the resulting object.


The path argument must be a handle to a NURBS Curve object (type 111). The profile argument must be a handle to an object of one of the following types: NURBS Curve, Polygon, Polyline, Arc, Rectangle, Rounded Rectangle, Line, Oval.

FUNCTION ExtrudeAlongPath(
pathHandle :HANDLE;
profileHandle :HANDLE) : HANDLE;
def vs.ExtrudeAlongPath(pathHandle, profileHandle):
    return HANDLE

Parameters

pathHandle HANDLE Handle to the path object.
profileHandle HANDLE Handle to the profile object.

Return Value

Returns a generic solid HANDLE to the new path extrude if successful, otherwise returns NIL.

Remarks

_c_, 2018.05.13: The generated extrusion is a Generic Solid and won't take the active class attributes, while CreateExtrudeAlongPath will create a number of NURBS curves with class attributes, but they won't section properly in Section Viewports without stitch and trim, since they don't generate a fill. Tested in Pio: OK.



The generic solid can not be edited

The following objects are supported as profile objects:

  • 2 - Line
  • 3 - Box
  • 4 - Oval
  • 5 - Polygon
  • 6 - Arc
  • 8 - Freehand
  • 13 - R Rect
  • 21 - Polyline
  • 25 - 3D Poly
  • 111 - NURBS Curve

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:CreateExtrudeAlongPath

VS Functions: [[VS:CreateExtrudeAlongPath]]