VS:DBSQLExecuteError: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:26, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return information about the last error occured in the ODBC API functions.

FUNCTION DBSQLExecuteError(
VAR message :DYNARRAY[] of CHAR;
VAR state :DYNARRAY[] of CHAR;
VAR code :LONGINT;
VAR internalDesc :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBSQLExecuteError():
    return (BOOLEAN, message, state, code, internalDesc)

Parameters

message DYNARRAY[] of CHAR
state DYNARRAY[] of CHAR
code LONGINT
internalDesc DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2012