VS:CreateSwapControl

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Create a swap control within a dialog.

This control manages multiple overlapping groups of controls, of which a single group of controls is displayed at a time. The script is able to control which group is displayed based on other data in the dialog. For example, a dialog may present a scrolling list of items on the left, and a swap control on the right. As the user selects items in the list, different sets of controls are enabled on the right. This can be used for a settings (preferences) style dialog or when there are too many choices to use a Tab control effectively.

PROCEDURE CreateSwapControl(
dialogID :LONGINT;
swapControlID :LONGINT);
def vs.CreateSwapControl(dialogID, swapControlID):
    return None

Parameters

dialogID LONGINT ID of the dialog.
swapControlID LONGINT ID of the swap control.

Remarks

The swap control is analogous to a tab control, except without the tabs. Thus, the script switches panes, not the user.

Version

Availability: from VectorWorks11.5

See Also

VS Functions:

VS:CreateSwapPane | VS:DisplaySwapPane

VS Functions:

[[VS:CreateSwapPane]]

| [[VS:DisplaySwapPane]]