VS:ColorIndexToRGB

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ColorIndexToRGB converts the VectorWorks palette colors from the colors' palette position index to its red, green, and blue component values.

RGB values are in the range of 0~65535. (Black: (0, 0, 0), White: (65535, 65535, 65535))

A color table listing with associated index values can be found in the Appendix

PROCEDURE ColorIndexToRGB(
color :INTEGER;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.ColorIndexToRGB(color):
    return (red, green, blue)

Parameters

color INTEGER Color index.
red LONGINT RGB color component value.
green LONGINT RGB color component value.
blue LONGINT RGB color component value.

Example

VectorScript

ColorIndexToRGB(45, r, g, b);
{returns the color value components of the color at position 45}

Python

r, g, b = vs.ColorIndexToRGB(45)

Version

Availability: from MiniCAD 6.0

See Also

Functions:

Functions:
  • [[VS:ColorIndexToRGBN| ColorIndexToRGBN]]
  • [[VS:RGBToColorIndex| RGBToColorIndex]]
  • [[VS:RGBToColorIndexN| RGBToColorIndexN]]
  • [[VS:GetPenFore]] | [[VS:GetPenBack]]| [[VS:GetFillFore]] | [[VS:GetFillBack]]