VS:ArcTo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure ArcTo creates an arc vertex with a point of intersection at the specified coordinate point.

The endpoints of the arc are tangent to the control segments which intersect at p. If a radius of 0 is passed as the parameter, the arc endpoints will be at the vertices preceding and following the arc spline vertex.

PROCEDURE ArcTo(
pX,pY :REAL;
radiusDistance :REAL);
def vs.ArcTo(p, radiusDistance):
    return None

Parameters

p REAL Coordinates of vertex.
radiusDistance REAL Radius of vertex arc.

Example

VectorScript

BeginPoly;
LineTo(-1",2");
LineTo(-2 1/2",1/2");
CurveTo(-1 1/2",-1 1/2");
LineTo(1",-1/2");
ArcTo(1",1 1/2",1/2");
EndPoly;
{creates a polyline object}

Python

vs.BeginPoly()
vs.LineTo(-1,2)
vs.LineTo(-2*12 - 1/2,1/2)
vs.CurveTo(-1*12 - 1/2,-1*12 - 1/2)
vs.LineTo(1,-1/2)
vs.ArcTo(1,1*12 + 1/2,1/2)
vs.EndPoly()
#{creates a polyline object}

Version

Availability: from MiniCAD4.0

See Also

AddPoint ArcTo BeginPoly ClosePoly
CurveThrough CurveTo DelVertex EndPoly
GetHole GetNumHoles GetPolyPt GetPolylineVertex
GetVertNum GetVertexVisibility InsertVertex OpenPoly
Poly SetPolyPt SetPolylineVertex SetVertexVisibility
Smooth

[[VS:AddPoint|AddPoint]] [[VS:ArcTo|ArcTo]] [[VS:BeginPoly|BeginPoly]] [[VS:ClosePoly|ClosePoly]] [[VS:CurveThrough|CurveThrough]] [[VS:CurveTo|CurveTo]] [[VS:DelVertex|DelVertex]] [[VS:EndPoly|EndPoly]] [[VS:GetHole|GetHole]] [[VS:GetNumHoles|GetNumHoles]] [[VS:GetPolylineVertex|GetPolylineVertex]] [[VS:GetPolyPt|GetPolyPt]] [[VS:GetVertexVisibility|GetVertexVisibility]] [[VS:GetVertNum|GetVertNum]] [[VS:InsertVertex|InsertVertex]] [[VS:OpenPoly|OpenPoly]] [[VS:Poly|Poly]] [[VS:SetPolylineVertex|SetPolylineVertex]] [[VS:SetPolyPt|SetPolyPt]] [[VS:SetVertexVisibility|SetVertexVisibility]] [[VS:Smooth|Smooth]]