VS:AddSolid

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function AddSolid creates a new solid addition object from the referenced source objects. If the operation succeeds, the source objects will then be contained within the newSolid object, as the primitives which define the CSG.

Table - Solids Operation Result Codes
Operation Result Result Code
Success 0
Null geometry error 1
Geometry error 2
Out of memory error 4
Bad group error 5
Invalid object type 6
Bad input 20
Handles not in document 21
FUNCTION AddSolid(
obj1 :HANDLE;
obj2 :HANDLE;
VAR newSolid :HANDLE) : INTEGER;
def vs.AddSolid(obj1, obj2):
    return (INTEGER, newSolid)

Parameters

obj1 HANDLE Handle to source object for add operation.
obj2 HANDLE Handle to source object for add operation.
newSolid HANDLE Handle to resultant object from add operation.

Example

VectorScript

PROCEDURE Example;
VAR
h1, h2, h3 :HANDLE;
int :INTEGER;
BEGIN
DSelectAll; BeginXtrd(0, 1); CallTool(-203); h1 := FSActLayer; EndXtrd;
DSelectAll; BeginXtrd(0, 1); CallTool(-203); h2 := FSActLayer; EndXtrd;
int := AddSolid(h1, h2, h3);
END;
RUN(Example);

Python


Version

Availability: from MiniCAD 7.0