VS:AddChoiceItem/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

カスタムダイアログにリストアイテムを作成します。リストアイテムの種類(1:ポップアップ/2:リストボックス(複数選択可)/3:リストボックス(複数選択不可))

PROCEDURE AddChoiceItem(
choiceTitle :STRING;
itemID :INTEGER;
choiceType :INTEGER;
x1 :INTEGER;
y1 :INTEGER;
x2 :INTEGER;
y2 :INTEGER);
def vs.AddChoiceItem(choiceTitle, itemID, choiceType, x1, y1, x2, y2):
    return None

Parameters

choiceTitle STRING リストアイテムのタイトル
itemID INTEGER リストアイテム番号(1から50まで)
choiceType INTEGER リストアイテムの種類
x1 INTEGER リストアイテムの左上のX座標
y1 INTEGER リストアイテムの左上のY座標
x2 INTEGER リストアイテムの右下のX座標
y2 INTEGER リストアイテムの右下のY座標

Example

AddChoiceItem('Topping Type',4,1,25,50,150,115);

Version

AddChoiceItem 廃止バージョン: Vectorworks 2010


利用可能バージョン: MiniCAD7.0

See Also

関連関数:

VS:InsertChoice

関連関数: [[VS:InsertChoice]]