VCOM:VectorWorks:Workspaces:IWorkspaces::ConvertStringToSafeXMLFormat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(New page: __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <desc> namespace <code>VectorWorks::Workspaces</code> Member o...)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Workspaces

Member of VCOM:VectorWorks:Workspaces:IWorkspaces

Converts a string to one that will be safe to store in the XML file. Bad strings in the XML file can cause exceptions to be thrown.

virtual VCOMError VCOM_CALLTYPE ConvertStringToSafeXMLFormat(
TXString& ioString) = 0;

Parameters

ioString TXString& on input, the normalized string, on output, the xml-safe string.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.