VCOM:VectorWorks:UI:IProgressDialog::HasUserCanceled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IProgressDialog

Checks if the user has clicked on 'Cancel' button of the dialog.

virtual VCOMError VCOM_CALLTYPE HasUserCanceled(
bool& bUserCanceled) = 0;

Parameters

bUserCanceled bool& Output parameter. Return true if the user have clicked 'Cancel' before the last call to this function.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.