VCOM:VectorWorks:UI:IProgressDialog::AllowUserCancel: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:07, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::UI

Member of VCOM:VectorWorks:UI:IProgressDialog

virtual VCOMError VCOM_CALLTYPE AllowUserCancel(
bool bAllow) = 0;

Parameters

bAllow bool true to allow 'Cancel' button which will cause the dialog to have 'Cancel' button. false -- there will be no 'Cancel' button.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.