VCOM:VectorWorks:Scripting:IVectorScriptEngine::RequestPredefinedCode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
 
(No difference)

Latest revision as of 13:54, 19 September 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::VectorScript

Member of VCOM:VectorWorks:VectorScript:IVectorScriptEngine

This function will display a dialog to allow the end-user to choose some predefined VectorScript code.

virtual VCOMErrorVCOM_CALLTYPE RequestPredefinedCode(
EPredefinedCodeRequest predefinedCodeType,
TXString& outCode) = 0;

Parameters

predefinedCodeType EPredefinedCodeRequest These are the different types of predefined code that the end-user can select: a predefined procedure, a criteria, an attribute of the tool (in the case of a tool script), a parameter (in the case of a plug-in with parameters), or a external file.
outCode SDK:TXString& This is the code that was selected by the user and should be inserted into the VectorScript Editor dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.