VCOM:VectorWorks:Scripting:IPythonWrapper::CompileText

From Vectorworks Developer
Revision as of 17:33, 19 September 2013 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonWrapper

Compile the specified text. Note that this routine will only fail on syntax errors and python has very relaxed syntax. For example it will not fail when a variable is not defined.

virtual bool VCOM_CALLTYPE CompileText(
const char* pythonCode) = 0;

Parameters

pythonCode const char* no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014