VCOM:VectorWorks:Scripting:IPythonWrapper::CompileText: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]
Member of [[VCOM:VectorWorks:Scripting:IPythonWrapper]]


...put some description here...
Compile the specified text. Note that this routine will only fail on syntax errors and python has very relaxed syntax.
For example it will not fail when a variable is not defined.
</desc>
</desc>


Line 15: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual boolVCOM_CALLTYPE CompileText(const char* pythonCode) = 0;
virtual bool VCOM_CALLTYPE CompileText(const char* pythonCode) = 0;
</funcDef>
</funcDef>
</def>
</def>

Latest revision as of 17:33, 19 September 2013

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonWrapper

Compile the specified text. Note that this routine will only fail on syntax errors and python has very relaxed syntax. For example it will not fail when a variable is not defined.

virtual bool VCOM_CALLTYPE CompileText(
const char* pythonCode) = 0;

Parameters

pythonCode const char* no info.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014