VCOM:VectorWorks:Scripting:IPythonScriptEngine::ReportRuntimeWarning: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Scripting:IPythonScriptEngine]]
Member of [[VCOM:VectorWorks:Scripting:IPythonScriptEngine]]


...put some description here...
Report a waring to the script engine. Errors collected during execution will be reported at the end of the execution with a dialog.
</desc>
</desc>


Line 25: Line 25:
text
text
const [[SDK:TXString]]&
const [[SDK:TXString]]&
no info.
The warning text.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 15:23, 19 September 2013

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonScriptEngine

Report a waring to the script engine. Errors collected during execution will be reported at the end of the execution with a dialog.

virtual VCOMErrorVCOM_CALLTYPE ReportRuntimeWarning(
const TXString& text) = 0;

Parameters

text const SDK:TXString& The warning text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014