VCOM:VectorWorks:Scripting:IPythonScriptEngine::ReportRuntimeError

From Vectorworks Developer
Revision as of 15:23, 19 September 2013 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonScriptEngine

Report an error to the script engine. Errors collected during execution will be reported at the end of the execution with a dialog.

virtual VCOMErrorVCOM_CALLTYPE ReportRuntimeError(
const TXString& text) = 0;

Parameters

text const SDK:TXString& The error text.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014