VCOM:VectorWorks:Scripting:IPythonScriptEngine::CallUserProcedure: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:Scripting:IPythonScriptEngine]]
Member of [[VCOM:VectorWorks:Scripting:IPythonScriptEngine]]


...put some description here...
This function is used to callback functions during execution of a script. For example, implementing a function that require to callback the script would use this call to execute the callback.
</desc>
</desc>


Line 25: Line 25:
procedureRef
procedureRef
void*
void*
no info.
Callback reference. This is provided through the Script Extension function parameter.
</line>
</line>
<line>
<line>
arguments
arguments
PluginLibraryArgTable*
PluginLibraryArgTable*
no info.
Argument table to be passed to the procedure.
</line>
</line>
<line>
<line>
argumentsCount
argumentsCount
size_t
size_t
no info.
Argument count in the table.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 15:25, 19 September 2013

Description

namespace VectorWorks::Scripting

Member of VCOM:VectorWorks:Scripting:IPythonScriptEngine

This function is used to callback functions during execution of a script. For example, implementing a function that require to callback the script would use this call to execute the callback.

virtual VCOMErrorVCOM_CALLTYPE CallUserProcedure(
void* procedureRef,
PluginLibraryArgTable* arguments,
size_t argumentsCount) = 0;

Parameters

procedureRef void* Callback reference. This is provided through the Script Extension function parameter.
arguments PluginLibraryArgTable* Argument table to be passed to the procedure.
argumentsCount size_t Argument count in the table.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.

Version

Availability: from Vectorworks 2014